Ontology for Modeling Adverse Outcome Pathways: Semantic tools for Systems Tox

Imran Shah

EPA-NIEHS Advancing Environmental Health Data Sharing and Analysis: Finding a Common Language
June 25, 2013

The views expressed in this presentation are those of the author[s] and do not necessarily reflect the views or policies of the U.S. Environmental Protection Agency.
Outline

➢ Challenge: Chemical Evaluation
➢ Problem: Linking chemical to potential health effect
➢ Approach: Adverse outcome pathway
➢ Solution: Semantic / knowledge-based tools
➢ Case-study
Challenge: Evaluating Chemicals

13,781/84,000 Chemicals on TSCA Inventory (so far)
Chemical Evaluation: A Complex Systems Problem

Problems:
- Exposure
- Adverse Outcome Pathways – Describe key components of the system from molecular to injury
- Dose-dependent responses – Simulate dynamic behaviour of system following chemical exposure

Semantic solution
- Domain-specific ontology – Toxicology
- Describe normal biology & chemical perturbation
- Enable automated reasoning
- Useful for quantitative modeling
Adverse Outcome Pathways

- Some history
  - Mode of Action (MoA) framework
  - 21st Century Tox – “Toxicity Pathways”
  - Conceptual framework for evaluating ecological outcomes

- On-going efforts:
  - OECD: Molecular Screening. Define “template” to standardize development and submission of AOPs for regulatory application
  - Effectopaedia: EU effort to store and organize AOPs
  - EPA AOP Wiki: EPA/CSS-OECD collaboration to curate AOPs
  - …. many other efforts …. 

- Standardization is important!

AOP: PPARα → Rodent Liver Cancer
Many possible pathways

Internal Dose → Molecular Effects → Cellular Functions → Cellular Effects → Adverse Outcomes

Absorption
Distribution
Metabolism
Excretion
Receptor Activation
Signal-transduction
Gene expression
Metabolism
Endoplasmic Reticulum
Mitochondrial Function
Peroxisomal Function
Cytoskeletal Architecture
Stress Pathways
Hepatocyte Necrosis
Apoptosis
Proliferation
Kupffer cell Activation
Phagocytosis
Hypertrophy
Injury
Inflammation
Regeneration
Steatosis
Cholestasis
Fibrosis
Cirrhosis
Hyperplasia
Pre-neoplasia
Neoplasia
Pathway Inference / Reconstruction

1. Define Hepatic Adverse Outcomes
   - Bottom-up – i.e. Data-driven – Computational tools organize evidence and use heuristics to generate hypotheses. Results not always relevant.
Data → Semantics → Knowledge

- Semantic model / Ontology
  - Referential vocabulary – standardize entities (things)
  - Relational vocabulary – standardize linkages
- Ontology for modeling Toxicity Pathways (OnToP):
  - Referential vocab (Table 1)
  - Relational vocab (BFO)
- Concretely expressed:
  - OWL/RDF
  - N3, Turtle, LISP, etc.
- SPARQL endpoint (Intranet)

Table 1. Named entities: classes, sources and instances

<table>
<thead>
<tr>
<th>Entity Class</th>
<th>Source(s)</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>chemical</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>KEGG</td>
<td>13681</td>
</tr>
<tr>
<td></td>
<td>DrugBank</td>
<td>7080</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>2607</td>
</tr>
<tr>
<td></td>
<td>NHANES</td>
<td>458</td>
</tr>
<tr>
<td></td>
<td>ToxCast</td>
<td>1658</td>
</tr>
<tr>
<td></td>
<td>ToxRefDB</td>
<td>307</td>
</tr>
<tr>
<td></td>
<td>NTP</td>
<td>586</td>
</tr>
<tr>
<td>gene</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>NCBI Entrez</td>
<td>143916</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>227</td>
</tr>
<tr>
<td>protein</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>UniProt</td>
<td>43900</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>4030</td>
</tr>
<tr>
<td>cell</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OBO: CellTypeOntology</td>
<td>983</td>
</tr>
<tr>
<td>cell-location</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>GO: CC</td>
<td>2110</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>204</td>
</tr>
<tr>
<td>anatomic-location</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OBO: FMA</td>
<td>75144</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>15</td>
</tr>
<tr>
<td>organism</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>NCBI Taxonomy</td>
<td>289</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>32</td>
</tr>
<tr>
<td>molecular-event</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OBO: GO molecular function</td>
<td>8360</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>83</td>
</tr>
<tr>
<td>cell-event</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OBO: GO biological process</td>
<td>17008</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>639</td>
</tr>
<tr>
<td>tissue-event</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OBO: MPO</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ToxRefDB</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td>MeSH</td>
<td>239</td>
</tr>
</tbody>
</table>

Shah et. al., PLOS Computational Biology (in revision)
DEHP and DCB were both able to suppress rat hepatocyte apoptosis.

Disturbances of the mitochondrial membrane, induced by CCl4 treatment, were also evidenced as increased mitochondrial swelling.

In DENA-initiated C3H and C3B6F1 mice, phenobarbital increased the labeling index in eosinophilic foci, while decreasing the labeling index in normal/non-involved hepatocytes with/without DENA initiation.

In contrast, PB, a non-genotoxic rodent hepatocarcinogen, enhances the growth of hepatic focal lesions in mice and rats by increasing cell proliferation and inhibiting apoptosis.

However, humans give a therapeutic response to the fibrate PPs via an alteration in lipid metabolism mediated by PPARalpha.

Acetaminophen treatment increased the plasma levels of aspartate transaminase, alanine aminotransferase, and alkaline phosphatase and caused hepatic DNA fragmentation and hepatocyte necrosis.

Shah et. al., PLOS Computational Biology (in revision)
Ontology for Toxicity Pathways: *OnToP*

- **Substances**
  - Measurable
  - Biological molecules, cell, anatomic locations, tissues
  - Organisms and their attributes
  - CAR, TCPOBOP, c-Myc
  - Liver, rat

- **Phenomena**
  - Events
  - Pathways: chain of events
  - CAR-activation, c-Myc-activation, cell proliferation, hyperplasia

- **Effects**
  - Changes in events
  - Chemical-effects
  - Latent-effects
  - TCPOBOP induced CAR-activation
  - FoxM1-activation increases cell proliferation
## Evidence from Literature

<table>
<thead>
<tr>
<th>Agent</th>
<th>Object</th>
<th>PMID</th>
<th>S</th>
<th>Phrase</th>
<th>Agent</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>Perfluorodecanoic acid</td>
<td>Nr1i2</td>
<td>15826607</td>
<td>1</td>
<td>PXR was markedly increased in rats treated with clofibrate and perfluorodecanoic acid</td>
<td>335-76-2</td>
<td>chemical</td>
</tr>
<tr>
<td>4-Nonylphenol</td>
<td>Nr1i2</td>
<td>16013040</td>
<td>2</td>
<td>4-Nonylphenol (4-NP) is an environmental estrogen that also can activate the pregnane X receptor</td>
<td>104-40-5</td>
<td>chemical</td>
</tr>
<tr>
<td>Diclofop-methyl</td>
<td>Ppara</td>
<td>17084873</td>
<td>7</td>
<td>diclofop-methyl and pyrethrins induce PPARalpha</td>
<td>51338-27-3</td>
<td>chemical</td>
</tr>
<tr>
<td>Perfluorooctanoic acid</td>
<td>Ppara</td>
<td>19162173</td>
<td>5</td>
<td>PFOA and PFOS elicited transcript profile signatures that included many known PPAR alpha target genes</td>
<td>335-67-1</td>
<td>chemical</td>
</tr>
<tr>
<td>Diisodecyphthalate</td>
<td>AhR</td>
<td>18294747</td>
<td>3</td>
<td>DIDP and DBP affected only the AhR</td>
<td>26761-40-0</td>
<td>chemical</td>
</tr>
<tr>
<td>Perfluorooctanoic acid</td>
<td>apoptosis</td>
<td>17374408</td>
<td>8</td>
<td>PFOA are able to produce oxidative stress and induce apoptosis</td>
<td>335-67-1</td>
<td>cell-event</td>
</tr>
<tr>
<td>Phenobarbital</td>
<td>hepatic hyperplasia</td>
<td>1236193</td>
<td>7</td>
<td>Phenobarbital treatment resulted in hyperplasia</td>
<td>50-60-6</td>
<td>tissue-event</td>
</tr>
<tr>
<td>Cyproterone acetate</td>
<td>hepatic hyperplasia</td>
<td>2139818</td>
<td>3</td>
<td>hepatomitogen cyproterone acetate (CPA) to induce liver hyperplasia</td>
<td>427-51-0</td>
<td>tissue-event</td>
</tr>
</tbody>
</table>

Shah et. al., PLOS Computational Biology (in revision)
DEHP apoptosis
epatocyte
rat

HTS data – molecular & cellular effects

Shah et. al., in preparation

Triclosan
PhI HepG2

MMP

Office of Research and Development
National Center for Computational Toxicology

Not for distribution
Workflow

Inputs:
- PubMed
- Gene Ontology
- KEGG
- MeSH
- UniProt
- Entrez Gene

Modules & Workflows:
- Information Retrieval
- Information Extraction
- Semantic Mapping
- Entity Identification
- Relation Extraction
- Public Data
- Format conversion
- Full-text searching

Outputs:
- MongoDB
- AllegroGraph
- REST/SPARQL

Office of Research and Development
Computational Toxicology Research Program
vLiver Knowledge-base

Formal Ontology
OWL/RDF; n3

Entities (with external links)
Chemicals > 13,781
Effects > 1,225,869
Assays > 38,294
Targets > 48,743

Sources:
PubMed >1e6
ToxCast 1008242
ToxRef 135512
PubMed/CTD: 82,020
PubMed/v-Liver: 2,302

Accessible:
SPARQL endpoint
REST

Literature – largest source of evidence ..
Case Study

• Browse evidence for chemicals
• Identify nuclear receptor activators
• Visualize evidence
• Making inferences about mechanisms
• Automated inference – pathways
• Hypothetical pathways to adverse outcomes
**WY-14643 Effects → Structured**

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096f**
  - Effect: dec HBA-A1 mRNA expression in mouse

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096e**
  - Effect: dec CYP2A mRNA expression in mouse

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096c**
  - Effect: dec ATP11C mRNA expression in mouse

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096d**
  - Effect: dec SLC25A5 mRNA expression in mouse

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096e**
  - Effect: dec HBA-A1 mRNA expression in rat

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096f**
  - Effect: dec HBA-A1 mRNA expression in rat

- **WY-14643 molecular-effect ID: 5153011b9743f479dbb00096g**
  - Effect: dec HBA-A1 mRNA expression in rat

- **WY-14643 tissue-effect ID: 5152102f9743f563a000704**
  - Effect: inc Apoptosis in Liver mouse
  - Trt: 25.0 mg/kg/day 13.0 week

- **WY-14643 tissue-effect ID: 5152102f9743f563a000705**
  - Effect: inc Apoptosis in Liver mouse
  - Trt: 25.0 mg/kg/day 13.0 week

- **WY-14643 tissue-effect ID: 5152102f9743f563a000706**
  - Effect: inc Apoptosis in Liver mouse
  - Trt: 25.0 mg/kg/day 13.0 week
Summary:
58 Chemicals
50 Targets
988 Effects
Chemical Effects \(\rightarrow\) Semantic View

Chemical Effects

- Increase
- Decrease
- No change

Molecular Event

Cellular Function

Histological Outcome

 Subset of experimental evidence about Phenobarbital (PB) from KB

Shah et. al., Bionformatics (in revision)
Semantics → Computational Inference

Prior Knowledge → Inference Algorithm → New “Knowledge”

PB → CYP3A4
PB → PXR
PXR → CYP3A4

NF-kappaB → PXR
PXR → Phenobarbital → CAR → CYP2B6

Chemical Effect
Latent Effects

Shah et. al., PLOS Comp Bio (in revision)
Plausible explanation of putative PB-mediated molecular changes

Evidence for Mdm2 activation by PB was not in the KB but has been shown experimentally

Hypotheses:
PB activates Mdm2 via CAR
PB activates FoxO1 via PXR

Shah et. al., PLOS Comp Bio (in revision)
### Computational Inference → "AOPs"

<table>
<thead>
<tr>
<th>Chemicals</th>
<th>Molecular</th>
<th>Cellular</th>
<th>Tissue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phebobarb/TCPOBOP</td>
<td>CAR &gt; FoxM1</td>
<td>Initiation &gt; promotion</td>
<td>Hyperplasia &gt; Neoplasia</td>
</tr>
<tr>
<td>Phebobarb/TCPOBOP</td>
<td>PXR &gt; ROS</td>
<td>DNA Damage &gt; Initiation &gt; promotion</td>
<td>Neoplasia</td>
</tr>
<tr>
<td>Phebobarb/TCPOBOP</td>
<td>CAR &gt; Mdm2</td>
<td>Apoptosis</td>
<td>??</td>
</tr>
</tbody>
</table>

**Hypothetical “AOPs” – require further curation**

Shah et. al., PLOS Comp Bio *(in revision)*
“AOPs” → Dose Response

Hepatocyte

Quantitative systems modeling – simulating changes in early cell-cycle progression using *in vitro* data

Summary

- Pathways – key to chemical evaluation
  - Interpreting HTS data for new chemicals
  - Quantitative dose-response modeling
- Approach: Data → Ontology → Knowledge → Inference → Hypotheses
- Implementation
  - Ontology for describing toxicity pathways (OWL/RDF)
  - Knowledge-base (KB) for capturing assertions (SPARQL)
  - KB Visualization tool (Cytoscape/c-Mantic)
  - Custom pathway-inference engine
- Broadly applicable to toxicology & AOPs
- Utility of ontology dependent on linkage with:
  - Public referential vocabularies
  - Public relational vocabularies